[Gephi-plugins] Dependency problem between plugins in latest Gephi 0.8 alpha

Hu Jin roger.hujin at gmail.com
Thu Sep 1 08:10:35 CEST 2011


Hi there,

I am new to gephi and just start trying to do some work on it. I get the
latest code with Bazaar and compiled in Netbeans 7.0.1. The code compiled
fine after I fixed up that junit4 dependency problem, but many plug-ins
refused to load when I run gephi.

I tried to reload some of the plug-ins manually by hitting "Reload in Target
Platform" while keeping gephi running and want to find out why these
plug-ins do not load. However, what I found in the output  window is the
module version mismatch.

For example, when I reload "Importer Plugin", the output windows shows:

java.io.IOException: Cannot enable
StandardModule:org.gephi.io.importer.plugin jarFile:
/home/test/Develop/gephi/build/cluster/modules/org-gephi-io-importer-plugin.jar;
problems: [module org.gephi.data.attributes.api > 0.7, module
org.netbeans.libs.junit4 > 1.7.1, module org.gephi.utils.longtask > 0.7,
module org.gephi.dynamic.api > 0.7, module org.gephi.io.importer.api > 0.7]

It looks Import Plugin requires AttributeAPI 0.7 specifically. So I checked
the dependency setting of "Import Plugin" module about the Attribute API as
the error message indicated "org.gephi.data.attributes.api > 0.7". The
settings shows Import Plug indeed depends on Attribute API and give the
"Specification Version 0.7".

Then, I checked the API version in Attribute API plug-in, it has the
Specification Version: 0.8.0.2, which is greater than 0.7 required, as what
the error message points out.

I checked a few other modules which refused to load and they all seems to
have this kind of mismatching dependency version numbers. I am not really if
I missed something here or it is the plug-ins do not have correct version
specified?

In the meantime, oddly enough, I installed Netbeans and Gephi on my Mac (OS
X 10.6) and it all compiled and runs no problem. I just cannot get it work
on my Ubuntu 10 linux box.


Any hints or suggestions will be appreciated.

Cheers,
Jin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://gephi.org/pipermail/gephi-plugins/attachments/20110901/d48508d9/attachment.html>


More information about the gephi-plugins mailing list